JetPlatform_binary permission denied error ?

Android system development related discussion

JetPlatform_binary permission denied error ?

Postby MadRocker » Tue Jun 14, 2011 5:19 am

Froyo branch.

Dopi, Sploutch I tried this but I keep on getting the permission denied error on keystore ... just after rild text show on screen during boot.

I ended up stripped everything leaving only /sbin /system, removed modules, removed ../etc, removed all ../hw except
Same error.

The rest of the files that is removed is not the problem, this error is deep in /system folder.
It could be that there needs to be a ../etc/??conf for permission to fix this for ../bin/sh not sure.

I had to chmod the android build folder last time I tried to build the platform.

I will try to upbuild the old froyo beta1 we have by adding some files from this froyo branch and see how far I get.

Hope this helps narrow the problem down.
Dev Team
Dev Team
Posts: 528
Joined: Sun Dec 12, 2010 7:15 am


Re: JetPlatform_binary permission denied error ?

Postby MadRocker » Sat Jun 18, 2011 6:34 am

Good news.

Dopi she boots to desktop. :D

I just used this froyo binary files to use as comparison once you have this working version versus default files.
Within this changed files/folders is the permission error, possibly gralloc.
Using this base and adding from JetFroyobeta1 files.

How-to get it to this stage:
del awdlauncher app
del init init.rc zImage

Add 18Feb FroyoBeta1 init.rc
Add 24March zImage
Add 18Feb 104.9kb init

hw folder so that only 24Mar is there then copy 16Jan + 16Jan .

24Mar all except 16Jan 111.4kb

ARM folders maybe not needed ??
12Jun CM611, 2x armeabi folders into .../lib

Modules is 13Jun

Add tss folder to .../lib for language selection from JetFroyoBeta1
Edit build.prop and remove 2nd 240 resolution and change first one to 200.

This takes a bit of time first time Welcome to GT-S8000 hands touches green android logo.

param and this kernel or init or combo causes a complaint that we can fix later.

Other optimizations / fixes can be done later. Might have to disable the 1st use setup in build.prop or check qwerty.kl .

Uploading to my github as temp/testing "JetPlatform_Froyo" , download and use as reference to fix / optimize the JetDroid github version.

Hope this helps. :D
Dev Team
Dev Team
Posts: 528
Joined: Sun Dec 12, 2010 7:15 am

Return to JetPlatform

Who is online

Users browsing this forum: No registered users and 1 guest

  • Advertisement