Cloned 8Feb video patch testing. NO wifi NO disk mount

JetPlatform (Eclair) testing releases will be posted here by the DevTeam. This forum is open for feedback from test users.
Forum rules
Dev Team members can post testing releases here. Please give a link to the source base that was used for a release or post patches / changelogs along with your binary packages.

Registered users can reply with their test feedback. Please only post test feedback here. For general (e.g. install related questions) please use the support Q&A section.

Re: Cloned 8Feb video patch testing. NO wifi NO disk mount

Postby MadRocker » Sat Feb 12, 2011 6:56 pm

HI Jose.

Working / not working the only way we can have it working = run a test and get 30fps to 50fps like in spica.
The names listed in the android.log is pretty but means nothing it just tells us the correct things is loaded = does not mean it is working or if working is it working good or working correct or working perfect as it should.

IE: we are going in the right direction to the train station, we are not on the train and we are not yet at the destination.
Sorry this is very confusing even for me. Below is what is the problem.

Maybe someone else here has better info and would like to share it but this is where I am at this time.
Code: Select all
[b]48hours of testing / trying to understand:[/b]
As far as I can understand about the video drivers is we have the s3cfb and this works with .../egl/libGLES_android.so .

Now you can use this default ....android.so or you can add the fimg files.
If you use the egl.cfg and change the option in there from  0 0 fimg or add 2 options and load 1 then other or more advanced do it is 4 steps. Either way the fimg is a miracle that it is there and even working.

[b]Example 4 steps:[/b]
[code]0 1 android
0 0 fimg[/code]
Loading = This will load (but not activate) android then load fimg then activate fimg and then activate android and changing this combination gets different results.

Most other phones either have only their fimg.so versions for their hardware or only run on android.so and uses the default s3cfb or powervx driver.

[b]Our problem is:[/b]
1. There is not a good guide to do this fimg config for the s3cfb so we have to smell and feel how to get this working. Some guides that is there works for other hardware.

2. The fimg / 3D files was built for other hardware see the post above with Spica and Jet hardware listed in the kernel.
This will make a huge difference once we built it for our actual hardware.

3. A proper build guide for the fimg files and what and where to put them correctly.
Some files I presume goes in the kernel ?? and some goes into the ~/JetDroid/android platform folder.
if so then we need to build a clean platform for (80mins each build time) eclair , froyo , ginger and then use that files "gralloc + chunk" and others for best results. 
Every time there is a fix can we cheat a build only this change or a complete platform rebuild ?

4. Once we get to this point we can use and modify the other egl / fimg config guides as then all the parts are in the correct place.

5. Then we would have to play with the settings to get it working in the best way and make our own guide.

At this time we have a shoe on that is 3 sizes too small but we need the shoe so we can walk over the broken glass = Spica ..../egl/fimg ect. using this in JetDroid.

[u]The files so far needed for video to work[/u] = s3cfb , fimg , 2D , 3D , gralloc , chunk + a init ?? and possibly a .conf ?? file.
This can be up to 4096 possible combination's and then you still have to hope this files is good and correct  / perfect that you started with and have no errors in them.

This 4096 does not include needed extra files in .../lib folder or some .../bin files.
Once we deal with this and make sure they are good then we should end up with a working good 3D.

This might be wrong but this is as far as I can get my hands around this problem. If we can get all this sorted out / made easier / stable then it should be much easier.
MadRocker
Dev Team
Dev Team
 
Posts: 528
Joined: Sun Dec 12, 2010 7:15 am

Advertisement

       

Re: Cloned 8Feb video patch testing. NO wifi NO disk mount

Postby l3w1n » Sun Feb 13, 2011 9:57 am

is there anyone who can help me with my problem?
l3w1n
Active member
Active member
 
Posts: 94
Joined: Thu Dec 09, 2010 3:57 pm

Re: Cloned 8Feb video patch testing. NO wifi NO disk mount

Postby MadRocker » Mon Feb 14, 2011 2:31 am

l3w1n
Try to do the 2 different chmod methods then it could help. If not then clean the sdcard ext3, chmod and then extract files then chmod.

There is 2 chmod commands you can use, sometimes both is needed.

Example on my phone:
Code: Select all
sudo chmod -R 777 /media/1.5gb
sudo chmod -R 777 /media/1.5gb/*
Change /media/1.5gb to your ext3 name maybe /media/JetDroid or /media/JETDROID ??

The wifi I am not sure but think you will need to have the files in both ../etc and in the wifi folder.

I got mine working but 3 mins into using the phone it only activated when I opened the sdcard using filemanager.apk .

l3w1n just use the 10Feb complete version as it is much easier to use.
MadRocker
Dev Team
Dev Team
 
Posts: 528
Joined: Sun Dec 12, 2010 7:15 am

Re: Cloned 8Feb video patch testing. NO wifi NO disk mount

Postby l3w1n » Mon Feb 14, 2011 7:47 pm

I have the 10feb version working (did not even have to du one chmod command^^) But when i move wifi files 1level up i get this problem. At the moment i can activate wifi (i have everything like in 10feb version) but it does not show network. And one more thing, when i want to write some text the keyboard shows up but i can neither change it to 123 nor i can see what i've written is this bug known in this version or is there maybe already a fix?
cheers
l3w1n
Active member
Active member
 
Posts: 94
Joined: Thu Dec 09, 2010 3:57 pm

Re: Cloned 8Feb video patch testing. NO wifi NO disk mount

Postby MadRocker » Wed Feb 16, 2011 5:25 am

I did get the wifi working by doing a lot of stuff. There seems to be a few funky files causing issues.

Process:
Open 31Jan Eclair .zip version then extract and replace this files / folders only.
/data -> replace all
/system/bin -> replace all
/system/etc -> replace all
/system/lib/* -> files only, not the folders.
/system/lib/egl -> remove all but leave 95.5kb android.so file.

/init.rc use 31Jan eclair init.rc .

With the fimg files removed there is no need for the crazy 10Feb init.rc .

Flicker is gone and wifi works, with filemanager.apk you might have automount working or same as in 31jan eclair.

So the extra files needed from the CM spica eclair is still there + now the working 31Jan eclair files, did not test automount or fimg but fimg / 3D we will need to rebuild them + chunk + copybit for next update.
For vibrate to work you will need to add the insmod and chmod /dev to the init.rc .

It appears that that fimg files is not needed to get rid of the flicker problem but rather some ../lib or ../bin file.

Now that we know this it might be easy enough to add some files / upgrade the 31Jan eclair or take this 10Feb eclair and downgrade to a good in-between version , this android.so 95.5kb is either ginger or froyo defaults so would need the extra libECT1.so and some other files if this android.so is the solution ??

Happy modding.
MadRocker
Dev Team
Dev Team
 
Posts: 528
Joined: Sun Dec 12, 2010 7:15 am

Re: Cloned 8Feb video patch testing. NO wifi NO disk mount

Postby Tinder-Red » Thu Feb 17, 2011 8:25 pm

MadRocker wrote:I did get the wifi working by doing a lot of stuff. There seems to be a few funky files causing issues.

Process:
Open 31Jan Eclair .zip version then extract and replace this files / folders only.
/data -> replace all
/system/bin -> replace all
/system/etc -> replace all
/system/lib/* -> files only, not the folders.
/system/lib/egl -> remove all but leave 95.5kb android.so file.

/init.rc use 31Jan eclair init.rc .

With the fimg files removed there is no need for the crazy 10Feb init.rc .

Flicker is gone and wifi works, with filemanager.apk you might have automount working or same as in 31jan eclair.

So the extra files needed from the CM spica eclair is still there + now the working 31Jan eclair files, did not test automount or fimg but fimg / 3D we will need to rebuild them + chunk + copybit for next update.
For vibrate to work you will need to add the insmod and chmod /dev to the init.rc .

It appears that that fimg files is not needed to get rid of the flicker problem but rather some ../lib or ../bin file.

Now that we know this it might be easy enough to add some files / upgrade the 31Jan eclair or take this 10Feb eclair and downgrade to a good in-between version , this android.so 95.5kb is either ginger or froyo defaults so would need the extra libECT1.so and some other files if this android.so is the solution ??

Happy modding.



Hello Madrocker.
I just do what you said but i can't mount the SDCard with filemanager.apk.
When i launch filemanager i can't found the SDCard.
What do i wrong?
Tinder-Red
Freshman
 
Posts: 4
Joined: Sat Dec 04, 2010 6:01 pm

Re: Cloned 8Feb video patch testing. NO wifi NO disk mount

Postby MadRocker » Thu Feb 17, 2011 9:00 pm

Tinder this is just some files you can add to your current version, this is testing so we need to make this files nice.

The mount part needs to be added to the init.rc to get it working + a few other things.
Best answer = You can look at other Eclair "JetDroid" version in the init.rc and you might need vold.fstab + possibly something else to make it work.
I think the 31Jan Eclair version is still good with wifi and auto disk mount but has flicker, might be easier for you to use that until we completed the no flicker patch for Eclair "JetDroid" .

From what I can see is we will likely throw 25% of this test patch files away for the next good patch to update 31Jan eclair version.
MadRocker
Dev Team
Dev Team
 
Posts: 528
Joined: Sun Dec 12, 2010 7:15 am

Re: Cloned 8Feb video patch testing. NO wifi NO disk mount

Postby Tinder-Red » Thu Feb 17, 2011 9:28 pm

THX for your quick answer.
I follow you guys on the forum all the time but there is a lot of files out there.
So i will waiting for the new all in one Jetdroid.
Tinder-Red
Freshman
 
Posts: 4
Joined: Sat Dec 04, 2010 6:01 pm

Re: Cloned 8Feb video patch testing. NO wifi NO disk mount

Postby MadRocker » Sat Feb 19, 2011 7:52 am

I am testing a patch, needs a bit more work, then I can upload it for both wifi and diskmount.

Disk mount uses the 2 thing = init.rc automount part and " /system/etc/vold.fstab " from Froyo beta1 or froyo patch files.
MadRocker
Dev Team
Dev Team
 
Posts: 528
Joined: Sun Dec 12, 2010 7:15 am

Re: Cloned 8Feb video patch testing. NO wifi NO disk mount

Postby Goodzila » Sat Feb 19, 2011 2:26 pm

I do not understand very well all these actions with the creation, but the drivers 2D/3D whether to approach from the I8000? They sort of stuff is made from I5700. Try to combine, they can already combined, take a look) http://www.megaupload.com/?d=H0UUDGGG
S8000XEIG2 - > S8000MXEIK1 -> S8000MXEJA1 [I use]
Running Android on Samsung Jet : [JetDroid]
I can help with the search programs for the android
Goodzila
Junior member
Junior member
 
Posts: 23
Joined: Thu Oct 21, 2010 3:30 pm
Location: Russia (Orenburg)

PreviousNext

Return to JetPlatform (Eclair) Testing

Who is online

Users browsing this forum: No registered users and 1 guest

  • Advertisement
cron